Wednesday, December 24, 2014

Dtrace on the Solaris Non-Global Zone

List solaris privileges in global-zone:

# ppriv -l “zone-name”

List of non-global zone privileges:

# zlogin “zone-name”

# ppriv -l “zone-name”  ( use -v for more verbose info)

How to use Dtrace

# zonecfg -z “zone-name”

zonecfg:zone-name> set limitpriv="default,dtrace_proc,dtrace_user"

zonecfg:zone-name> exit

Now boot the zone:

# zoneadm -z “zone-name” boot

Now log in:

# zlogin “zone-name”

Run Dtrace utility:

# dtrace -l

Trick:

You can run the commands on the fly the same way you execute
the commands over SSH on the local zone from the global


# zlogin “zone-name” svcs -a | grep -i ssh



====================================

No comments: